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1) Description:
The PICAXE datalogger is an economical four
channel datalogger based upon the PICAXE-18X or
18M2 microcontroller. This microcontroller can be
re-programmed to perform many different types of
logging experiment (“mission”).
Logging can be carried out at regularly spaced
intervals (typically 10 seconds to several hours), or
an optional real-time-clock chip can be added to
the datalogger to ensure accurate logging intervals over long periods (once a week, once a month etc.)
Data is saved in an external memory chip. If desired this memory chip can be upgraded for increased
memory capacity. An optional memory expansion board can also be used to greatly increase memory
capacity.
Once the mission is complete, data can be uploaded for analysis on a computer. Data can also be
displayed (at the time of logging) on an optional liquid crystal display if desired.
Programming of the mission is simplified by use of automated ‘Wizards’, which generate the BASIC code
to download to the PICAXE-18X or 18M2 microcontroller. Experienced users may also choose to write
their own mission BASIC code (or to modify the programs generated by the automated wizard).

Features:
•
•
•
•
•
•
•
•
•

Easy to use software wizards to start datalogging missions.
Supports PICAXE-18X / 18M2 microcontroller and on-board EEPROM data memory.
4 logging channels.
Dedicated digital temperature sensor channel.
Small footprint - approx. same size as the power supply (3x AA cells).
Optional real-time-clock with lithium cell backup (AXE034)
Optional serial LCD module for on-board display of data (AXE033)
Expandable i2c bus for additional EEPROM memory capacity (AXE111)
Low power consumption, powered by 3x AA cells.

The datalogger is available as a pre-assembled complete unit.

For the full datasheet please see www.rev-ed.co.uk/docs/axe110.pdf
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Input Channels
The datalogger has 4 input channels (labelled
0,1,2,7)
Input 0 is normally used for a miniature light sensor
(LDR – light dependant resistor). The miniature LDR
is connected via the two screw terminals in terminal
block CT6. This input is pre-configured as a potential
divider with a 10k pull-down resistor.

V+
Input1
0V

Input0
V+

Inputs 1 and 2 are arranged for connection of your
own sensors (analogue or digital). Each input pin,
and V+ and 0V, are connected to terminal blocks CT3
and CT4. No pull-down resistors are present on the
board, and so should be connected externally (if
required).

0V
Input7
V+

V+
Input2
0V

Input 7 is pre-configured for use with a DS18B20
digital temperature sensor. This is connected via
terminal block CT5. The flat side of the sensor faces
down when connecting the sensor into the terminal
block.

Memory
The datalogger kit is supplied with a 24LC16B EEPROM memory chip. This can
store 2048 byte readings (8 blocks of 256 bytes). This usually enables 512 readings
for each of the four sensors.
If desired, the memory capacity can be increased by replaced this EEPROM with a
24LC256 EEPROM (part MIC050). This can store 32768 bytes of data (128 blocks
of 256 bytes).
For additional data storage capacity the optional AXE111 memory expansion board
can be used. This allows an additional seven 24LC256 to be connected, giving a
total of 2MB of memory (1024 blocks of 256 bytes).

Power Supply
The datalogger is designed to run from a 3xAA battery pack (3 x 1.5V = 4.5V with
alkaline cells). If using rechargeable cells a 4xAA pack should be used to (4 x 1.2V =
4.8V).
The positive (red) wire should be connected to V+ on the terminal block connector
CT7. The negative (black) wire should be connected to GND. When connecting the
wires it is recommended that the bare wire is bent back over the insulation, and
then the screw tightened on both. This gives a much stronger joint.
If a wall-plug adapter is used it must be a very high quality regulated unit. It must
output exactly 4.5V or 5V DC only. Note that very cheap wall-adapters are often
unregulated devices that may cause the datalogger to function incorrectly.
Connection of a higher voltage (e.g. a 9V PP3 battery), or accidentally reversing the
power supply connections, will damage the ICs and digital temperature sensor on
the datalogger. These will then require replacing.
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Serial / USB Cable Connections
The datalogger has two sockets for connection of the serial cable. CT1, marked ‘Run’
is to connect the cable when it is necessary to reprogram the PICAXE
microcontroller to start a new mission. CT2, marked ‘Datalink’ is to connect the
cable for transfer of mission data between the PICAXE chip and computer.

Optional Real Time Clock (RTC) Upgrade
The optional real time clock upgrade (part AXE034) consists of a DS1307 RTC chip
and a 3V lithium CR2032 backup cell. When inserted into the datalogger sockets,
this upgrade adds additional accurate clock functionality. Note that the RTC needs
to be initialised (by setting the current time/date by using the time/date wizard)
before it will function correctly. The lithium cell will maintain the time and date for
approximately 10 years.

Additional Outputs
The datalogger has a bicolour LED (LED2) connected between outputs 2 and 3.
Switching output 2 high and output 3 low will produce a green colour. Switching
output 2 low and output 3 high will produce a red colour.
Note that the green LED (LED1) is connected to the square wave output of the
optional DS1307 RTC chip, not the PICAXE chip. It will automatically flash on and
off every second when the DS1307 chip is inserted (and initialised by the time/date
wizard). This LED cannot be controlled directly by the PICAXE chip.
An optional piezo sounder (part SPE002) can be connected to output 0 via the
holes marked PZ on the left hand side of the board. A ‘sound’ command can then
be used to generate information and/or warning signals.
An optional serial LCD module (part AXE033) can be connected to output 6 via the
holes marked LCD on the right hand side of the board. ‘Serout’ commands can
then be used to display data on the serial LCD module. Note that the serial LCD
module is designed to work at 6V, and so will only operate correctly at 4.5V if the
diode D1 on the serial LCD module is bypassed with a piece of wire.

Using the Datalogger:
Normal Use
To program the datalogger for a mission, most users use the simple ‘Wizards’ which
automatically generate the correct BASIC program for the PICAXE microcontroller.
See the ‘Starting a new Datalogger mission’ section on page 8 for more information.

Advanced Use
Advanced users may choose to write their own programs, to, for instance, allocate
the memory to different sensors or to increase or decrease the logging period. In
this case it is strongly recommended that the user carefully studies a ‘wizard
generated’ sample program as a tutorial in how to write the BASIC for the
datalogger module. It is also strongly recommended that the user has read the
‘Tutorial in using the i2c bus’ (AXE110_i2c.pdf), which explains how to use the
24LCxx series EEPROM memories and the DS1307 real-time-clock.
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2) Self-Assembly Kit - Overview:
The PICAXE datalogger board is a high quality plated through PCB and is therefore relatively straight forward
to assemble. However a number of the electronic components are polarised, so please ensure these
components are fitted the correct way around before soldering (see table on next page).
Note that a pre-assembled kit is also available for those with no soldering experience.
Tools required (not supplied):
• Soldering iron and solder
• Side Cutters
• Small pair of pliers
Soldering experience is assumed.

Contents:
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•

PCB
IC1
IC2,3
R1,2
R3,4,5
R6,7,8,9
R10,11
C1,2
C3
LED1
LED2
S1
X1
CT1,2
CT3,4,5
CT6,7
CT8
BAT1

1
1
2
2
3
4
2
2
1
1
1
1
1
2
3
2
1
1

PICAXE Datalogger PCB
18 pin IC socket
8 pin IC socket
22k resistor (red red orange gold)
10k resistor (brown black orange gold)
4k7 resistor (yellow violet red gold)
470 resistor (yellow violet brown gold)
100nF (104) polyester capacitor
100uF electrolytic capacitor
*** + marked on PCB
green LED
*** flat marked on PCB
bicolour LED
*** flat marked on PCB
miniature push switch
miniature watch crystal
3.5mm stereo socket
3 pin screw terminal block (may be supplied clipped together)
2 pin screw terminal block (may be supplied clipped together)
5 pin r/a connector
CR2032 cell holder

•
•
•

LDR
1
DS18B20 1
POWER 1

miniature LDR (use in connector CT6)
digital temperature sensor (use in connector CT5) *** flat side faces solder side of pcb
4.5V battery box (use in connector CT7)
*** red wire to V+, black to GND

•
•

IC1
IC3

PICAXE-18X or 18M2 microcontroller
24LC16B EEPROM

1
1

*** pin 1 faces up
*** pin 1 faces up

(*** denotes components which must be soldered the correct way around. See notes above).
(IC2 & cell (AXE034) and piezo sounder PZ (SPE002) are optional upgrades not included in pack)
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Assembly Instructions:

1. Solder the resistors in position. Note the pads marked LK1 under the 4k7/470
resistors are not used.
2. Solder the watch crystal in position X1. Note the can of the crystal can be
soldered on top of the PCB to secure it in position.
3. Solder the three IC sockets and push switch S1 in position.
4. Solder the CT1 and CT2 connectors in place. Ensure these stereo sockets ‘click’
into position flat on the PCB prior to soldering.
5. Solder the capacitors and LEDs in position
6. Solder the remaining connectors in position. Note that where the screw
terminals are fitted side by side they should be clipped together before
soldering.
7. Solder the BAT1 battery conector in position.
8. Insert the PICAXE (IC1) and 24LC16B (IC3) into their sockets.
Optional Upgrades
9. If using the optional RTC upgrade (AXE034) insert the IC into socket IC2 and
the battery into it’s holder.
10. If using an optional piezo sounder (SPE002) solder it in position PZ
11. If using the optional serial LCD (AXE033), connect it to the LCD header.
Note that LED1 will not flash unless the optional RTC upgrade is fitted and the
DS1307 RTC clock chip has been initialised.
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4) PICAXE Datalogger Input/Output Pin Connections:

Output 0
Output 1
Output 2
Output 3
Output 4
Output 5
Output 6
Output 7

- piezo sounder (optional - PZ)
- i2c SDA
- bicolour LED red
- bicolour LED green
- i2c SCL
- EEPROM Write Enable
- serial LCD (optional - LCD)
- datalink serial output

V+
Input1
0V
V+
Input2
0V

Serial Connection
The PICAXE download ‘run’ connection uses ther standrad
PICAXE programming pins.

serial out
serial in
0V

Run CT1

The datalink connection uses input 6 for ‘serin’ serial
commands and output 7 for ‘serout’ serial commands.

22k

x
x

x
x

10k

x

Default Sensors

Input0
V+

- LDR light sensor (connector CT6)
- spare sensor input 1 (CT3)
- spare sensor input 2 (CT4)
- datalink serial input
- DS18B20 temp. sensor (CT5)

0V
Input7
V+

Analogue Input 0
Analogue Input 1
Analogue Input 2
Digital Input 6
Digital Input 7

PICAXE
output 7
input 6
0V

Datalink CT2

The datalogger is supplied with two sensors, and has
capacity for an additional 2 sensors (not supplied). Note
the power connections and inputs are labelled on the
solder side of the PCB.

22k

x
x

x
x

10k

x

LDR

The DS18B20 digital temperature sensor can be connected
into terminal block CT5, so that it is connected to input7 of
the PICAXE microcontroller. The flat side of the sensor
should face down as it is connected into the terminal block.
The digital temperature sensor is a very accurate device
which will give readings in exact degrees celsius by use of
the ‘readtemp’ command.
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4k7

LDR
V+
input
pin7

DS18B20

DS18B20 Digital temperature Sensor
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4.5V

input
pin0

temperature
sensor

V+
data
0V

0V

PICAXE

A miniature LDR (light dependant resistor) can be
connected into terminal block CT6, so that it is connected
to input0 of the PICAXE microcontroller.
The light level can then be measured by use of the ‘readadc’
command.

10k

0V
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5) Starting a new Datalogging Mission.
1.
2.
3.
4.

Start the Programming Editor software
Select View>Options and select PICAXE-18X or 18M2 mode. Click OK.
Select PICAXE>Wizards>AXE110 Datalogger>Start New Datalogger Mission
Select the datalogging mission options and then click ‘OK’.

Note that once a datalogger program is downloaded, the mission starts running
automatically, and data is saved in the external memory. It is not possible to reset
the mission by use of the RESET button on the datalogger, as the data is saved in the
external EEPROM. Therefore to start a new mission you must download a new
program.
The New Datalogging Mission wizard screen looks like this:

The ‘Sensors’ box allows up to four sensors to be selected. Each sensor can also be
named with a text string (up to 16 characters) which is saved in the PICAXE
memory.
The ‘Memory’ box allows the type of memory used to be selected. Note that the 4
and 8 x 24LC256 options require use of the optional memory expansion board
(part AXE011).
The ‘Logging Period’ box allows the interval between readings to be selected.
There are three options for general time intervals:
sleep – uses the sleep command to reduce power consumption, but is the least
accurate
pause – more accurate, but increased power consumption than the sleep option
DS1307 RTC – most accurate, but requires RTC upgrade
There is also a fourth option to select readings at specific time/dates using the RTC
upgrade. This is generally used on much longer datalogging missions.
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The ‘Readings’ box allows the number of mission samples to be selected (up to the
memory limit).
The ‘Outputs’ box allows selection of various outputs as follows:
- Use bi-colour LED
If selected, the status LED will flash green every time a reading is taken. When the
mission is complete (or the memory is full) the LED will turn red. If a memory
error occurs, the LED will alternately flash red/green.
- Use piezo sounder
If selected, the optional piezo sounder (SPE002) will beep every time a reading is
taken.
- Use speech
If selected, the optional speech module (SPE020) will speak the readings as they are
taken. Note that the SPE020 module is discontinued and no longer available.
- Use serial LCD
If selected, the optional serial LCD module (AXE033) will display the readings as
they are taken.
- Use EE WP on AXE111
If selected, output6 is used as a write-enable for the AXE111 memory expansion
board. Note this option cannot be used at the same time as the serial LCD option,
as both options use output6. If selected, a jumper wire should be soldered across
the pads marked LK1 on the bottom of the AXE110 datalogger module.
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6) Retrieving Data from a Datalogging Mission.
The ‘Datalink’ communications utility is used to retrieve mission data from the
AXE110 Datalogger module. The utility saves the data in CSV (comma separated
variable) format files, which can be opened in all common spreadsheet applications
(e.g. Microsoft Excel) for further analysis. The utility also includes the option to
automatically draw a graph of the data as it is uploaded (if required).
To use the ‘Datalink’ communications utility, a small BASIC program must be
running in the PICAXE microcontroller. This program reads the data from memory
and transmits it (via the ‘Datalink’ connector and serial cable) to the computer,
where it can be processed by the ‘Datalink’ utility. This BASIC program is always
automatically downloaded as part of a ‘New Datalogger Mission’ wizard program.
Note that the ‘Datalink’ utility uses the standard PICAXE cable to retrieve the data
from the datalogger module. However this cable must be inserted into the
‘Datalink’ socket (not the PICAXE ‘Run’ socket) for the ‘Datalink’ utility to function
correctly.
Note: If you are unsure whether the datalogger has the correct BASIC program
already running, a suitable program can be downloaded by using a program wizard
(use menu option PICAXE>Wizard>AXE110 Datalogger>Retrieve Unknown Data).
However this wizard should only be used if a normal datalogging program is not
already running (see the AXE110 datalogger
manual for further information).
Instructions on how to use the Datalink Utility:
1. Wait until the datalogger mission is complete
(status LED red).
2. Connect the PICAXE cable to the Datalink
socket on the datalogger.
3. Start the Programming Editor software.
4. Select PICAXE>Datalink menu (or press
<F9> shortcut key).
5. Select the Options menu. Make sure the
options are set to
Baud Rate
– 4800
Sensors
– (1 to 4 as appropriate)
Send G
– enabled
6. If you would like the software to
automatically draw a graph as data is
uploaded, make sure the graph is visible on
screen by selecting the ‘Graph…’ check box.
7. Click the File>New menu, and then follow
the on-screen instructions.
8. The data will then be uploaded, and is
immediately visible on screen. Once the data
upload is complete, click the File>Save As
menu to save the data as a CSV format text
file. This file can then be opened (if desired)
in other applications such as Microsoft Excel.
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7) Using the AXE034 Real Time Clock Upgrade
The optional real time clock upgrade (part AXE034) consists of a DS1307 RTC (realtime-clock) chip and a 3V lithium CR2032 backup cell. When inserted into the
datalogger, the upgrade adds additional accurate clock functionality. Note that the
RTC needs to be initialised (by setting the current time/date) by the PICAXE chip
before it will function correctly. The lithium backup cell will maintain the time and
date for approximately 10 years.
Setting of the time and date can be completed without having to write a BASIC
program by use of a Wizard.
To set the time/date:
1. Start the Programming Editor software
2. Select View>Options and select PICAXE-18X or 18M2 mode. Click OK.
3. Select PICAXE>Wizards>AXE110 Datalogger>Set DS1307 Time / date

1.
2.
3.
4.

Set the time and date manually, or use the date from the computers clock.
Connect the programming cable to the ‘Run’ socket on the AXE110 Datalogger.
Connect the power supply to the AXE110 Datalogger.
Click ‘OK’ on screen.

A BASIC program to program the RTC will be generated and downloaded to the
datalogger module. Once programming is complete the values are checked by the
PICAXE microcontroller, and then the status LED will be lit (green for pass, red for
fail).
If the ‘Flash LED’ option has been selected, the green LED on the datalogger should
also start flashing once per second.
After the programming is complete, it is important to download an empty program
to the PICAXE microcontroller to prevent the time being accidentally re-set the next
time the datalogger is powered up.

8) Using the AXE033 Serial LCD Module
The optional AXE033 Serial LCD module can be used to display datalogging
readings as they are taken. This module uses the serout command on output 6. To
use this module connect the serial LCD module to the LCD connector on the right
hand side of the datalogger. Note that the serial LCD module is designed to work at
6V, and so will only operate correctly at 4.5V if the diode D1 on the serial LCD
module is bypassed with a piece of wire. See the AXE033 datasheet for more details.
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9) Using the AXE111 Memory Expansion Board
The optional memory expansion board (part AXE111) allows 7 additional EEPROM
chips (e.g. 24LC256) to be connected to the AXE110 Datalogger to increase its
memory capacity from 1 EEPROM to 8 EEPROMs.

Kit Contents/Assembly:
PCB
IC1-7
C1
R1
CT1
CT2

PCB
8 pin IC sockets (x7)
100nF capacitor
10k resistor
5 pin r/a header
5 pin r/a socket

All parts should be soldered in position as shown
in the diagram above. Note that the kit does not
include EEPROM chips which must be purchase
separately (e.g. 24LC256, part MIC050).
Slave Address
The PCB is arranged to give each memory IC a
unique slave address as follows. (Note that the IC
with address %10100000 is fitted on the AXE110
datalogger board).
IC1
IC2
IC3
IC4
IC5
IC6
IC7

%10100010
%10100100
%10100110
%10101000
%10101010
%10101100
%10101110

Write Enable
The Write Enable pin of each EEPROM is tied low by the 10k resistor, and so by
default is permanently enabled. However, if desired, this can be controlled by
output6 of the PICAXE microcontroller on the datalogger module.
To use this option a wire link must be soldered between the two pads marked LK1
on the solder side of the AXE110 Datalogger. This connects output6 to the
connector. Note that this option cannot be used if output6 is already being used to
drive a serial LCD module.

10) Using the SPE030 Speech Module (discontinued).
The optional SPE030 speech module can be used to speak datalogging readings as
they are taken. This module uses the i2c bus. To use this module insert the bottom
5 pins (i2c and power) of the SPE030 PL1 connector into the AXE110 i2c connector
(CT8). See the SPE030 datasheet for more information on how to use this module.
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11) Using the SEN008 Humidity Sensor (Honeywell HIH4000-001).
There are various humidity sensors on the market, but the
recommended device for use with the PICAXE datalogger is
the Honeywell HIH4000-001. This sensor is a direct humidity
to voltage device (with linear output), and it even has three
pins which can plug straight into the datalogger terminal
block connector CT4 (input1).
As with all humidity sensors, take care not to physically touch
the sensing area of the device, as moisture/oils from the hand
could damage the sensitive sensor element. When inserted
into CT4 the small silver sensing area should be facing up.
A sample graph of the response of the humidity sensor is
shown in the figure. When used with the PICAXE, the voltage
output of the sensor is measured by the internal analogue-todigital converter and stored in a variable (e.g. b1) as a number
between 0 and 255. Each ADC step is 5V/256 = 0.0195V
(assuming use of a regulated 5V supply).
The manufacturers calibration graph shows an offset of approximately 0.8V, which
equate to a ADC value of 41 (0.8 / 0.0195). The RH slope is set at about 0.0306V
per %RH, or 1.57 ADC step per %RH
Therefore the actual RH% can be calculated by the following calculation.
RH = adc value – offset / (slope of graph)
RH = adc value – 41 / (1.57)
However as PICAXE cannot handle fractions, divide by 1.57 is actually calculated as
a mathematical equivalent - multiply by 100 then divide by 157.
RH = adc value – 41 * 100 / 157
Checking these test values against a calibrated test probe using the test program
shown below showed the resulting PICAXE system to be very accurate. However you
may need to ’tweak’ the offset and slope figures depending on sensor calibration,
power supply voltage etc.
main:
readadc 1,b1
‘ read humidity value
let b1 = b1 - 41 * 100 / 157 ‘ change to %RH
debug b1
‘ display on computer screen
pause 500
‘ wait 0.5 second
goto main
‘ loop
.
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